Quagga Case Study 4 Quagga A Config
!
hostname Router
hostname ospfd
hostname bgpd
bgp config-type cisco
!
password zebra
enable password password
!
interface eth0
ip address 10.0.2.2/24
ipv6 nd suppress-ra
link-detect
!
interface eth1
ip address 100.0.2.2/24
ipv6 nd suppress-ra
link-detect
!
interface lo
ip address 50.0.1.2/32
link-detect
!
router bgp 65001
no synchronization
bgp router-id 50.0.1.2
network 10.200.1.0 mask 255.255.255.0
network 50.0.1.2 mask 255.255.255.255
redistribute connected
redistribute ospf
neighbor 10.0.1.1 remote-as 65001
neighbor 100.0.2.4 remote-as 65004
neighbor 100.0.2.4 route-map r2 in
no auto-summary
!
router ospf
redistribute connected metric 2000
redistribute bgp metric 2000
network 10.0.2.0/24 area 0.0.0.0
!
route-map r2 permit 10
set local-preference 222
!
ip forwarding
!
line vty
no login
!