Quagga Case Study 4 Cisco 3750 Config
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco_3750_L3
!
enable secret 5 $1$xaQB$o3kE.kAqbVym4U7G0l3ta.
!
no aaa new-model
switch 1 provision ws-c3750-24ts
ip subnet-zero
ip routing
!
ip multicast-routing distributed
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Loopback1
ip address 50.0.1.1 255.255.255.255
!
interface FastEthernet1/0/1
!
interface FastEthernet1/0/2
switchport access vlan 2
!
interface FastEthernet1/0/3
!
interface FastEthernet1/0/4
!
interface FastEthernet1/0/5
!
interface FastEthernet1/0/6
!
interface FastEthernet1/0/7
!
interface FastEthernet1/0/8
!
interface FastEthernet1/0/9
!
interface FastEthernet1/0/10
!
interface FastEthernet1/0/11
!
interface FastEthernet1/0/12
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface Vlan1
ip address 10.0.1.1 255.255.255.0
!
interface Vlan2
ip address 100.0.1.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
redistribute connected metric 1000 metric-type 1 subnets
redistribute bgp 65001 metric 1000 metric-type 1 subnets
network 10.0.1.0 0.0.0.255 area 0
!
router bgp 65001
no synchronization
bgp router-id 50.0.1.1
bgp log-neighbor-changes
network 10.200.1.1 mask 255.255.255.0
network 50.0.1.1 mask 255.255.255.255
redistribute connected
redistribute ospf 1
neighbor 10.0.2.2 remote-as 65001
neighbor 100.0.1.3 remote-as 65003
neighbor 100.0.1.3 route-map r2 in
no auto-summary
!
ip classless
ip http server
ip http secure-server
!
route-map r2 permit 10
set local-preference 333
!
control-plane
!
line con 0
line vty 0 4
no login
line vty 5 15
no login
!
end