Tutorials Vyatta Case Study 8 Config Cisco A

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco-RouterA
!
enable secret 5 $1$Znt3$yMy6kMk9NxEipffq2VziU1
!
ip subnet-zero
!
crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share
group 2
lifetime 7200
crypto isakmp key eden address 100.0.0.1
!
crypto ipsec security-association lifetime seconds 1800
!
crypto ipsec transform-set t1 esp-3des esp-md5-hmac
!
crypto map m1 110 ipsec-isakmp
set peer 100.0.0.1
set transform-set t1
match address 111
!
call rsvp-sync
!
interface Loopback1
ip address 10.250.1.1 255.255.255.255
!
interface FastEthernet0/0
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
ip address 50.0.0.1 255.255.255.0
duplex auto
speed auto
crypto map m1
!
ip classless
ip route 10.200.1.1 255.255.255.255 100.0.0.1
ip route 100.0.0.1 255.255.255.255 50.0.0.2
no ip http server
!
access-list 111 permit ip 10.250.0.0 0.0.255.255 10.200.0.0 0.0.255.255
!
dial-peer cor custom
!
line con 0
line aux 0
line vty 0 4
no login
!
end