TOTAL
Depuis Dec 2006
1'942'871 Visiteurs
4'218'042 Pages

Stats Nov 2010
82'909 Visiteurs
146'476 Pages
196 pays
Statistiques completes



Aidez-nous à traduire
nos tutoriaux!

REJOINGNEZ
l'équipe OpenManiak.
SNORT_INLINE - Le Tutorial Facile - Prérequis

Snort_Inline Prérequis
Dernière modif: Dec 06 2007


Outil
Installation
Ergonomie
Forum



Détails Snort_Inline, c'est quoi?
Captures d'écran
Prérequis
Installation
Oinkmaster - Règles Snort
Oinkmaster - Règles Bleeding
Lancer Snort_Inline
BASE
Construire un pont (bridge)



⚠️⚠️⚠️
Please check our page about COVID-19!!
100 Questions and answers about Coronavirus.

⚠️⚠️⚠️
Merci de consulter notre page sur la COVID-19 !!
227 questions et réponses sur le Coronavirus.


Les programmes suivants sont requis pour lancer Snort_Inline avec BASE:

APACHE2 - serveur web.
Version installée sur notre Linux: 2.0.55

#apt-get install apache2
MySQL - base de données.
Version installée: 5.0.22

#apt-get install mysql-server
PHP5 - langage de script orienté serveur.
Version installée: 5.1.2

#apt-get install php5
PHP5-MySQL
Version installée: 5.1.2

#apt-get install php5-mysql
BUILD-ESSENTIAL - metapackage contenant des outils pour compiler et installer des
programmes.
Version installée: 11.1

#apt-get install build-essential
PCRE - librairie de fonctions utilisant la même syntaxe et sémantique que Perl 5.
Version installée: 6.4.1

#apt-get install libpcre3-dev
IPTABLES-DEV - Set de règles de filtrage pour Linux.
Version installée: 1.3.3

#apt-get install iptables-dev
LIBNET - interface de programmation générique réseau qui fournit un accès à plusieurs
protocoles.
Version installée: 1.0.2a-7

#apt-get install libnet0-dev
Soyez attentif à ne pas installer libnet 1.1.x (package libnet1-dev). Sinon, comme indiqué sur le site web de Snort_Inline, la compilation de Snort_Inline contre cette version de libnet ne fonctionnera pas.

LIBRAIRIE MYSQLCLIENT - librairies de développement MySQL et fichiers "header".
Version installée: 4.0.24

#apt-get install libmysqlclient12-dev
CHECKINSTALL - suppression facile des programmes installés depuis la source.
Version installée: 1.6.0

#apt-get install checkinstall
Obtenez plus d'information sur checkinstall.

LIBDNET - interfacage vers des routines réseaux de bas niveau.
Version installée: 1.11

Comme il n'y a pas de package disponible pour libdnet, vous devez l'installer manuellement:
Téléchargez et décompressez libdnet:

#tar -xvf libdnet-1.11.tar.gz
Accédez au dossier libdnet et installez la librairie:

#cd libdnet-1.11
#./configure
#make
#checkinstall