TOTAL
Depuis Dec 2006
1'942'871 Visiteurs
4'218'042 Pages

Stats Nov 2010
82'909 Visiteurs
146'476 Pages
196 pays
Statistiques completes



Aidez-nous à traduire
nos tutoriaux!

REJOINGNEZ
l'équipe OpenManiak.
QUAGGA - Le Tutorial Facile - Étude 4 - BGP

Quagga Étude 4 - BGP
Dernière modif: Dec 06 2007


Tool
Installation
Ergonomie
Forum



Détails Quagga, c'est quoi?
Prérequis & Installation
Comment utiliser Quagga
Comparaison des fonctionnalités de routeurs
Étude de cas 1 - routes statiques
Étude de cas 2 - OSPF simple
Étude de cas 3 - OSPF avancé
Étude de cas 4 - BGP




If you like our tutorials, don't hesitate to support us and visit our sponsors!
Si vous aimez nos tutoriaux, n'hésitez pas à nous supporter et visiter nos sponsors!



1. PRINCIPE 2. SCHÉMA 3. CONFIGURATIONS 4. COMMANDES SHOW 5. BASCULEMENT
Voir un scénario similaire avec le routeur Vyatta.



1. PRINCIPE

Quelques mots à propos de BGP.

Ce tutorial est dédié au protocole de routage dynamique BGP (Border Gateway Protocol) dont la quatrième et dernière version est sortie en 1994.

BGP est principalement utilisé par les fournisseurs d'accès (providers) pour gérer le routage sur internet ou pour fournir de la connectivité entre les sites distants d'une société avec des technologies comme MPLS.

BGP n'est pas dimensionné pour des environnements petits à moyens (environ jusqu'à 100 routeurs) en raison de son temps de convergence lent comparé aux protocoles de routage OSPF et RIP. En même temps, il peut être très complexe à configurer et a besoin de matériel très puissant et donc très cher pour tourner de manière confortable.
C'est pourquoi, BGP ne devrait être utilisé que par des fournisseurs d'accès ou par des compagnies possédant un très grand nombre de routeurs.

Par exemple, les entrées BGP dans un routeur Internet sont, en juillet 2007, plus de 200'000 et croissent tous les jours. En raison du grand nombre de routes, la variation de la table de routage requière une quantité importante de ressources et en conséquence de quoi, le matériel doit être très puissant.
Cisco Systems (avec ses routeurs de la série 12000) et Juniper se partagent ce très lucratif marché.
Pour des réseaux privés, il est aussi possible d'utiliser BGP sur des routeurs plus "petits" comme les routeurs de la série 7200 ou 3800. Bien sûr, Quagga supporté par une bonne "appliance" peut aussi être à l'aise dans cet environnement.

Deux points forts de BGP sont:
-
 
-
 
 
Utilisation de TCP. BGP communique avec les autres routeurs BGP (appelés "peers") à travers le protocole TCP qui est le protocole de transport le plus fiable.
La notion de système autonome (autonomous system, AS). Il s'agit d'un groupe de réseaux IP sous une administration commune et avec des stratégies de routages communes.
Nous vous donnons, dans les tableaux ci-dessous quelques points clefs pour comparer BGP avec deux autres protocoles de routage bien connus: OSPF et RIP ainsi que quelques explications du processus de sélection du meilleur chemin BGP (BGP best path selection).

Référez-vous à la documentation sur Internet ou achetez-vous un livre pour acquérir des informations supplémentaires sur ce protocole de routage complexe.

Comparaison des protocoles de routage:

  RIP OSPF BGP
Version: v2 v2 v4
RFC: 2453 2328 1771
Date: 1998 1998 1994
       
IGP - EGP: (1) IGP IGP EGP
Type: Distance vector
(Vecteur de distance)
Link state
(Etat de lien)
Path vector
(Vecteur de chemin)
Algorithme: Bellman-Ford Dijkstra Best Path Selection
       
Convergence: (2) Moyenne Rapide Lente
Distance administrative: 120 110 20
Niveau OSI et port: UDP / 520 IP / 89 TCP / 179
       
Complexité de configuration: Facile Moyenne Haute à très haute
Granularité du routage: Routeur Routeur Système autonome (3)
Dimensionné pour: < 100 routeurs < 100 routeurs > 100 routeurs
Consommation de ressource: Faible Faible à Moyenne Haute
(1)
 
 
 
(2)
 
(3)
 
IGP signifie Interior Gateway Protocols (Protocoles de passerelle intérieur), EGP signifie Exterior Gateway Protocols (Protocoles de passerelle extérieur).
Les EGPs sont utilisés entre des entités d'administration indépendantes, souvent appelées systèmes autonomes et les IGPS sont utilisés à l'intérieur de ces derniers.
Temps de convergence: temps nécessaire aux routeurs à synchroniser leur table de routage après un changement dans la topologie réseau.
Quand plusieurs chemins sont disponibles pour un réseau spécifique, BGP choisit la route traversant le plus petit nombre de systèmes autonomes.
Processus de sélection du chemin BGP:

Le processus de sélection du chemin BGP est utilisé s'il existe plusieurs routes disponibles pour un réseau. Vous pouvez le voir avec la commande "show ip bgp". Cette commande ne doit pas être confondue avec la commande "show ip route" où uniquement les meilleures routes sont affichées à l'écran.

Pour obtenir des détails complets, vous pouvez lire la page web Cisco à propos du processus de sélection du chemin BGP.
Cliquez sur un nom d'attribut pour consulter un exemple.

  NOM d'ATTRIBUT PRÉFÉRENCE TRANSMISSION DE LA VALEUR DESCRIPTION
1. Weight (a)
(Poids)
Le plus grand Locale au router Cisco & Quagga specific
2. Local Preference
(Préférence Locale)
La plus grande Globale à l'intérieur de l'AS Comment sortir de l'AS si chemins multiples
3. Path
(Chemin)
La plus courte    
4. Origin Code
(Code d'origine)
La plus petite   IGP ou "i" < EGP ou "e" < Incomplet ou "?" (b)
5. MED (Metrique) La plus petite Transmise aux ASs voisins uniquement  
(a)
(b)
 
Par défaut, un réseau directement connecté prend un poids (weight) de 32768.
Un code d'origine (origin code) incomplet (caractère "?") est du aux redistributions de routes dans BGP.
Principe de l'étude de cas

Voici les fonctionnalités que nous allons tester dans notre scénario BGP:

-
 
 
 
-
 
 


 
 
 
 
-
 
 
 
-
 
 
 
-
 
 
 
EBGP (external BGP): BGP entre systèmes autonomes (AS).
EBGP is activé entre Cisco 3750 L3 et Cisco 2651 A, Cisco 2651 A et Quagga B, Quagga B et Cisco 2651 C, Cisco 2651 et Quagga A.

IBGP (Internal BGP): BGP à l'intérieur d'un AS.
IBGP est activé entre Cisco 3750 L3 et Quagga A.

Redistribution BGP dans OSPF:
Sur Cisco 3750 L3: les routes BGP sont injectées dans OSPF avec une métrique de 1000 et marquées en OE1.
On Quagga A: les routes BGP sont injectées dans OSPF avec une métrique de 2000 et marquées en OE2 (défaut).

Redistribution OSPF dans BGP:
Sur Cisco 3750 L3 et Quagga A, les réseaux OSPF sont injectés dans BGP avec les valeurs par défaut.

Préférence locale: Cisco 3750 L3 est le routeur préféré pour sortir de l'AS 65001
Des préférences locales personnalisées sont appliquées via des "route maps" aux routes entrantes sur Cisco 3750 L3 (333) et Quagga A (222).

MED. Quagga B va préférer le chemin via AS 65003 plutôt que via l'AS 65004 pour atteindre l'AS 65001.
Des MED personnalisées sont appliquées via des "route maps" sur les routes BGP sortantes vers l'AS 65005 sur Cisco 2651 B (55) et Cisco 2651 C (99).



2. SCHÉMA

vyatta cisco case study BGP Fonctionnalités testées::

(cliquez sur les liens internet pour avoir plus de détails sur un protocole)

Interface settings
OSPF - backbone area
BGP
Redistr. - BGP to OSPF
Redistr. - OSPF to BGP
Telnet access

 
 
 
 
 
 
 
 
   
 
 
 
 
   
 
 
 
 
   
 
 
 
 
   
 
 
 
 
 
 
 
Haut de la page



3. CONFIGURATIONS

Vous devez configurer votre système Linux correctement pour pouvoir lancer Quagga avec succès.
Référez-vous au tutorial Quagga pour de l'assistance.
LINUX CONFIGURATIONS

Vérifiez que les démons ospfd, bgpd et zebra sont activés sur Quagga A:

#vim /etc/quagga/daemons
zebra=yes
bgpd=yes
ospfd=yes
ospf6d=no
ripd=no
ripngd=no
isisd=no


Vérifiez que les démons bgpd et zebra sont activés sur Quagga B:

#vim /etc/quagga/daemons
zebra=yes
bgpd=no
ospfd=yes
ospf6d=no
ripd=no
ripngd=no
isisd=no


Si vous avez effectués des changements dans vos fichiers daemon, redémarrez le service quagga:

#vim /etc/init.d/quagga restart
Configurez le nom d'hôte (hostname) de Quagga A dans le fichier /etc/quagga/vtysh.conf:

#vim /etc/quagga/vtysh.conf
!
! Sample
!
! service integrated-vtysh-config
hostname Quagga_A
username root nopassword
!


Configurez le nom d'hôte (hostname) de Quagga B dans le fichier /etc/quagga/vtysh.conf:

#vim /etc/quagga/vtysh.conf
!
! Sample
!
! service integrated-vtysh-config
hostname Quagga_B
username root nopassword
!


N'oubliez pas d'activer la redirection IP (IP forwarding) sur les routeurs Quagga A et B!

CONFIGURATIONS DES ROUTEURS

ROUTER 2651 A IOS: 12.2-23a
Voir la configuration complète
 

 
 
interface FastEthernet0/1
  ip address 10.0.2.99 255.255.255.0
  no shutdown
interface FastEthernet0/0
  ip address 10.0.1.99 255.255.255.0
  no shutdown
interface Loopback 1
  ip address 50.0.1.99 255.255.255.255
Cisco_2651_A
router ospf 1
  network 10.0.1.0 0.0.0.255 area 0
  network 10.0.2.0 0.0.0.255 area 0
  network 50.0.1.99 0.0.0.0 area 0
line vty 0 4
  no login
enable secret password

SWITCH L3 3750
IOS: 12.2-25.SEE2
Voir la configuration complète
 

QUAGGA A
0.99.6
Voir la configuration complète
 
interface vlan 1
  ip address 10.0.1.1 255.255.255.0
  no shutdown
interface FastEthernet1/0/1
  switchport access vlan 1
interface eth0
  ip address 10.0.2.2/24
  link-detect
 
 
interface vlan 2
  ip address 100.0.1.1 255.255.255.0
  no shutdown
interface FastEthernet1/0/2
  switchport access vlan 2
interface eth1
  ip address 100.0.2.2/24
  link-detect
 
 
interface Loopback 1
  ip address 50.0.1.1 255.255.255.255
 
interface lo
  ip address 50.0.1.2/32
  link-detect
hostname Cisco_3750_L3
router ospf 1
  redistribute connected metric 1000
  metric-type 1 subnets
  redistribute bgp 65001 metric 1000
  metric-type 1 subnets
  network 10.0.1.0 0.0.0.255 area 0
router ospf
  redistribute connected metric 2000
 
  redistribute bgp metric 2000
 
  network 10.0.2.0/24 area 0.0.0.0
 
router bgp 65001
  no synchronization
  bgp router-id 50.0.1.1
  network 50.0.1.1 mask 255.255.255.255
  redistribute connected
  redistribute ospf 1
  neighbor 10.0.2.2 remote-as 65001
  neighbor 100.0.1.3 remote-as 65003
  neighbor 100.0.1.3 route-map r2 in
  no auto-summary
bgp config-type cisco
router bgp 65001
  no synchronization
  bgp router-id 50.0.1.2
  network 50.0.1.2 mask 255.255.255.255
  redistribute connected
  redistribute ospf
  neighbor 10.0.1.1 remote-as 65001
  neighbor 100.0.2.4 remote-as 65004
  neighbor 100.0.2.4 route-map r2 in
  no auto-summary
route-map r2 permit 10
  set local-preference 333
route-map r2 permit 10
  set local-preference 222
line vty 0 4
  no login
line vty
  no login
enable secret password
 
enable password password
 
ip routing
ip multicast-routing distributed

ROUTER 2651 B
IOS: 12.2-23a
Voir la configuration complète
 

QUAGGA B
0.99.6
Voir la configuration complète
 
interface FastEthernet0/0
  ip address 100.0.1.3 255.255.255.0
  no shutdown
interface eth0
  ip address 200.0.1.5/24
  link-detect
interface FastEthernet0/1
  ip address 200.0.1.3 255.255.255.0
  no shutdown
interface eth1
  ip address 200.0.2.5/24
  link-detect
interface Loopback 1
  ip address 50.0.1.3 255.255.255.255
 
interface lo
  ip address 50.0.1.5/32
  link-detect
hostname Cisco_2651_B
router bgp 65003
  bgp router-id 50.0.1.3
  network 50.0.1.3 mask 255.255.255.255
  redistribute connected
  neighbor 100.0.1.1 remote-as 65001
  neighbor 200.0.1.5 remote-as 65005
  neighbor 200.0.1.5 route-map r3 out
  no auto-summary
router bgp 65005
  bgp router-id 50.0.1.5
  network 50.0.1.5 mask 255.255.255.255
  redistribute connected
  neighbor 200.0.1.3 remote-as 65003
  neighbor 200.0.2.4 remote-as 65004
 
  no auto-summary
route-map r3 permit 10
  set metric 55
line vty 0 4
  no login
line vty
  no login
enable secret password enable password password

ROUTER 2651 C IOS: 12.2-23a
Voir la configuration complète
 

 
 
interface FastEthernet0/0
  ip address 100.0.2.4 255.255.255.0
  no shutdown
interface FastEthernet0/1
  ip address 200.0.2.4 255.255.255.0
  no shutdown
interface Loopback 1
  ip address 50.0.1.4 255.255.255.255
router bgp 65004
  bgp router-id 50.0.1.4
  network 50.0.1.4 mask 255.255.255.255
  redistribute connected
  neighbor 100.0.2.2 remote-as 65001
  neighbor 200.0.2.5 remote-as 65005
  neighbor 200.0.2.5 route-map r99 out
  no auto-summary
hostname Cisco_2651_C
route-map r99 permit 10
  set metric 99
line vty 0 4
  no login
enable secret password
Haut de la page



4. COMMANDES SHOW

CISCO 2651 A CISCO 3750 L3 QUAGGA A CISCO 2651 B QUAGGA B CISCO 2651 C
CISCO 2651 A

Cisco_2651_A#show ip int brief

Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.0.1.99 YES NVRAM up up
FastEthernet0/1 10.0.2.99 YES NVRAM up up
Loopback1 50.0.1.99 YES NVRAM up up
Cisco_2651_A#show ip route

Codes:   C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route
       
Gateway of last resort is not set
       
    50.0.0.0/32 is subnetted, 6 subnets
O E1   50.0.1.3 [110/1001] via 10.0.1.1, 00:37:09, FastEthernet0/0
O E2   50.0.1.2 [110/2000] via 10.0.2.2, 00:37:15, FastEthernet0/1
O E1   50.0.1.1 [110/1001] via 10.0.1.1, 00:37:15, FastEthernet0/0
O E1   50.0.1.5 [110/1001] via 10.0.1.1, 00:36:22, FastEthernet0/0
O E1   50.0.1.4 [110/1001] via 10.0.1.1, 00:35:56, FastEthernet0/0
C     50.0.1.99 is directly connected, Loopback1
    100.0.0.0/24 is subnetted, 2 subnets
O E1   100.0.1.0 [110/1001] via 10.0.1.1, 00:37:15, FastEthernet0/0
O E2   100.0.2.0 [110/2000] via 10.0.2.2, 00:12:48, FastEthernet0/1
O E1 200.0.1.0/24 [110/1001] via 10.0.1.1, 00:37:09, FastEthernet0/0
O E1 200.0.2.0/24 [110/1001] via 10.0.1.1, 00:36:22, FastEthernet0/0
    10.0.0.0/24 is subnetted, 2 subnets
C     10.0.2.0 is directly connected, FastEthernet0/1
C     10.0.1.0 is directly connected, FastEthernet0/0
Cisco_2651_A#show ip ospf database

  OSPF Router with ID (50.0.1.99) (Process ID 1)
     
    Router Link States (Area 0)
             
Link ID   ADV Router Age Seq# Checksum Link count
50.0.1.1   50.0.1.1 357 0x80000004 0x003417 1
50.0.1.2   50.0.1.2 555 0x80000004 0x00CC90 1
50.0.1.99   50.0.1.99 404 0x80000005 0x00236B 3
             
    Net Link States (Area 0)
             
Link ID   ADV Router Age Seq# Checksum  
10.0.1.99   50.0.1.99 404 0x80000002 0x009CCC  
10.0.2.99   50.0.1.99 404 0x80000002 0x009FC7  
             
    Type-5 AS External Link States
             
Link ID   ADV Router Age Seq# Checksum Tag
50.0.1.1   50.0.1.1 357 0x80000002 0x005B84 0
50.0.1.2   50.0.1.2 502 0x80000003 0x00C3CA 0
50.0.1.3   50.0.1.1 357 0x80000002 0x00BB38 65003
50.0.1.4   50.0.1.1 357 0x80000002 0x00B141 65003
50.0.1.5   50.0.1.1 357 0x80000002 0x00A74A 65003
100.0.1.0   50.0.1.1 357 0x80000002 0x00D8D5 0
100.0.2.0   50.0.1.2 834 0x80000001 0x00441B 0
200.0.1.0   50.0.1.1 357 0x80000002 0x00342C 65003
200.0.2.0   50.0.1.1 357 0x80000002 0x002936 65003
CISCO 3750 L3

Cisco_3750_L3#show ip int brief

Interface IP-Address OK? Method Status Protocol
Vlan1 10.0.1.1 YES NVRAM up up
Vlan2 100.0.1.1 YES NVRAM up up
FastEthernet1/0/1 unassigned YES NVRAM up up
FastEthernet1/0/2 unassigned YES NVRAM up up
... ... ... ... ... ...
Loopback1 50.0.1.1 YES NVRAM up up
Cisco_3750_L3#show ip route

Codes:   C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route
       
Gateway of last resort is not set
       
    50.0.0.0/32 is subnetted, 6 subnets
B     50.0.1.3 [20/0] via 100.0.1.3, 00:41:15
O E2   50.0.1.2 [110/2000] via 10.0.1.99, 00:41:20, Vlan1
C     50.0.1.1 is directly connected, Loopback1
B     50.0.1.5 [20/0] via 100.0.1.3, 00:40:27
B     50.0.1.4 [20/0] via 100.0.1.3, 00:40:01
O     50.0.1.99 [110/2] via 10.0.1.99, 00:41:20, Vlan1
    100.0.0.0/24 is subnetted, 2 subnets
C     100.0.1.0 is directly connected, Vlan2
O E2   100.0.2.0 [110/2000] via 10.0.1.99, 00:16:53, Vlan1
B   200.0.1.0/24 [20/0] via 100.0.1.3, 00:41:15
B   200.0.2.0/24 [20/0] via 100.0.1.3, 00:40:27
    10.0.0.0/24 is subnetted, 3 subnets
O     10.0.2.0 [110/2] via 10.0.1.99, 00:41:20, Vlan1
C     10.0.1.0 is directly connected, Vlan1
Cisco_3750_L3#show ip ospf database

  OSPF Router with ID (50.0.1.1) (Process ID 1)
     
    Router Link States (Area 0)
             
Link ID   ADV Router Age Seq# Checksum Link count
50.0.1.1   50.0.1.1 631 0x80000004 0x003417 1
50.0.1.2   50.0.1.2 832 0x80000004 0x00CC90 1
50.0.1.99   50.0.1.99 680 0x80000005 0x00236B 3
             
    Net Link States (Area 0)
             
Link ID   ADV Router Age Seq# Checksum  
10.0.1.99   50.0.1.99 680 0x80000002 0x009CCC  
10.0.2.99   50.0.1.99 680 0x80000002 0x009FC7  
             
    Type-5 AS External Link States
             
Link ID   ADV Router Age Seq# Checksum Tag
50.0.1.1   50.0.1.1 631 0x80000002 0x005B84 0
50.0.1.2   50.0.1.2 779 0x80000003 0x00C3CA 0
50.0.1.3   50.0.1.1 631 0x80000002 0x00BB38 65003
50.0.1.4   50.0.1.1 631 0x80000002 0x00B141 65003
50.0.1.5   50.0.1.1 631 0x80000002 0x00A74A 65003
100.0.1.0   50.0.1.1 631 0x80000002 0x00D8D5 0
100.0.2.0   50.0.1.2 1111 0x80000001 0x00441B 0
200.0.1.0   50.0.1.1 632 0x80000002 0x00342C 65003
200.0.2.0   50.0.1.1 632 0x80000002 0x002936 65003
Cisco_3750_L3#show ip bgp summary

BGP router identifier 50.0.1.1, local AS number 65001
BGP table version is 16, main routing table version 16
13 network entries using 1469 bytes of memory
24 path entries using 1248 bytes of memory
18/10 BGP path/bestpath attribute entries using 1944 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 4733 total bytes of memory
BGP activity 13/0 prefixes, 24/0 paths, scan interval 60 secs
                   
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.2.2 4 65001 58 64 16 0 0 00:44:16 13
100.0.1.3 4 65003 54 53 16 0 0 00:45:14 6
Cisco_3750_L3#show ip bgp

BGP table version is 16, local router ID is 50.0.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
      r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
                 
    Network   Next Hop Metric LocPrf Weight Path
* i 10.0.1.0/24   10.0.2.99 11 100 0 ?
*>       0.0.0.0 0   32768 ?
* i 10.0.2.0/24   10.0.2.2 1 100 0 ?
*>       10.0.1.99 2   32768 ?
* i 50.0.1.1/32   10.0.2.99 1011 100 0 ?
*>       0.0.0.0 0   32768 i
r> i 50.0.1.2/32   10.0.2.2 0 100 0 i
* i i50.0.1.3/32   10.0.2.99 1011 100 0 ?
*>       100.0.1.3 0 333 0 65003 i
* i 50.0.1.4/32   10.0.2.99 1011 100 0 ?
*>       100.0.1.3   333 0 65003 65005 65004 i
* i 50.0.1.5/32   10.0.2.99 1011 100 0 ?
*>       100.0.1.3   333 0 65003 65005 i
* i 50.0.1.99/32   10.0.2.99 11 100 0 ?
*>       10.0.1.99 2   32768 ?
* i 100.0.1.0/24   10.0.2.99 1011 100 0 ?
*       100.0.1.3 0 333 0 65003 ?
*>       0.0.0.0 0   32768 ?
r> i 100.0.2.0/24   10.0.2.2 1 100 0 ?
* i 200.0.1.0   10.0.2.99 1011 100 0 ?
*>       100.0.1.3 0 333 0 65003 ?
* i 200.0.2.0   10.0.2.99 1011 100 0 ?
*>       100.0.1.3   333 0 65003 65005 ?
Haut de la page       Menu commandes show

QUAGGA A

Quagga_A#show interface description

Interface Status Protocol Description
eth0 up up  
eth1 up up  
lo up up  
Quagga_A#show ip route

Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
    I - ISIS, B - BGP, > - selected route, * - FIB route
     
O>*   10.0.1.0/24 [110/11] via 10.0.2.99, eth0, 01:11:01
O   10.0.2.0/24 [110/10] is directly connected, eth0, 01:11:48
C>*   10.0.2.0/24 is directly connected, eth0
O>*   50.0.1.1/32 [110/1011] via 10.0.2.99, eth0, 01:10:16
C>*   50.0.1.2/32 is directly connected, lo
O>*   50.0.1.3/32 [110/1011] via 10.0.2.99, eth0, 01:10:02
O>*   50.0.1.4/32 [110/1011] via 10.0.2.99, eth0, 01:08:48
O>*   50.0.1.5/32 [110/1011] via 10.0.2.99, eth0, 01:09:14
O>*   50.0.1.99/32 [110/11] via 10.0.2.99, eth0, 01:11:01
O>*   100.0.1.0/24 [110/1011] via 10.0.2.99, eth0, 01:10:16
C>*   100.0.2.0/24 is directly connected, eth1
C>*   127.0.0.0/8 is directly connected, lo
O>*   200.0.1.0/24 [110/1011] via 10.0.2.99, eth0, 01:10:02
O>*   200.0.2.0/24 [110/1011] via 10.0.2.99, eth0, 01:09:14
Quagga_A (Linux level)#route -n

Destination Gateway Genmask Flags Metric Ref Use Iface
50.0.1.1 10.0.2.99 255.255.255.255 UGH 1011 0 0 eth0
50.0.1.99 10.0.2.99 255.255.255.255 UGH 11 0 0 eth0
50.0.1.3 10.0.2.99 255.255.255.255 UGH 1011 0 0 eth0
50.0.1.5 10.0.2.99 255.255.255.255 UGH 1011 0 0 eth0
50.0.1.4 10.0.2.99 255.255.255.255 UGH 1011 0 0 eth0
10.0.1.0 10.0.2.99 255.255.255.0 UG 11 0 0 eth0
10.0.2.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
100.0.2.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
200.0.1.0 10.0.2.99 255.255.255.0 UG 1011 0 0 eth0
200.0.2.0 10.0.2.99 255.255.255.0 UG 1011 0 0 eth0
100.0.1.0 10.0.2.99 255.255.255.0 UG 1011 0 0 eth0
Quagga_A#show ip ospf database

  OSPF Router with ID (50.0.1.2)
             
    Router Link States (Area 0.0.0.0)
             
Link ID   ADV Router Age Seq# CkSum Link count
50.0.1.1   50.0.1.1 292 0x80000005 0x3218 1
50.0.1.2   50.0.1.2 693 0x80000005 0xca91 1
50.0.1.99   50.0.1.99 311 0x80000006 0x216c 3
             
    Net Link States (Area 0.0.0.0)
             
    ADV Router     CkSum  
10.0.1.99   50.0.1.99   0x80000003 0x9acd  
10.0.2.99   50.0.1.99   0x80000003 0x9dc8  
             
    AS External Link States
             
Link ID   ADV Router Age Seq# CkSum Route
50.0.1.1   50.0.1.1 292 0x80000003 0x5985 E1 50.0.1.1/32 [0x0]
50.0.1.2   50.0.1.2 611 0x80000004 0xc1cb 50.0.1.2/32 [0x0]
50.0.1.3   50.0.1.1 292 0x80000003 0xb939 50.0.1.3/32 [0xfdeb]
50.0.1.4   50.0.1.1 292 0x80000003 0xaf42 50.0.1.4/32 [0xfdeb]
50.0.1.5   50.0.1.1 292 0x80000003 0xa54b 50.0.1.5/32 [0xfdeb]
100.0.1.0   50.0.1.1 292 0x80000003 0xd6d6 100.0.1.0/24 [0x0]
100.0.2.0   50.0.1.2 1431 0x80000002 0x421c 100.0.2.0/24 [0x0]
200.0.1.0   50.0.1.1 292 0x80000003 0x322d 200.0.1.0/24 [0xfdeb]
200.0.2.0   50.0.1.1 292 0x80000003 0x2737 200.0.2.0/24 [0xfdeb]
Quagga_A#show ip bgp summary

BGP router identifier 50.0.1.2, local AS number 65001
RIB entries 25, using 1600 bytes of memory
Peers 2, using 5024 bytes of memory
                   
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.1.1 4 65001 89 85 0 0 0 01:11:27 10
100.0.2.4 4 65004 57 53 0 0 0 00:46:37 5
                   
Total number of neighbors 2
Quagga_A#show ip bgp

BGP table version is 0, local router ID is 50.0.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
      r RIB-failure, S Stale, R Removed
Origin codes: i - IGP, e - EGP, ? - incomplete
                 
    Network   Next Hop Metric LocPrf Weight Path
* i 10.0.1.0/24   10.0.1.1 0 100 0 ?
*>       10.0.2.99 11   32768 ?
* i 10.0.2.0/24   10.0.1.99 2 100 0 ?
*>       0.0.0.0 1   32768 ?
* i 50.0.1.1/32   10.0.1.1 0 100 0 i
*>       10.0.2.99 1011   32768 ?
*   50.0.1.2/32   0.0.0.0 1   32768 ?
*>       0.0.0.0 0   32768 i
*>   50.0.1.3/32   10.0.2.99 1011   32768 ?
* i     100.0.1.3 0 333 0 65003 i
*   50.0.1.4/32   100.0.2.4 0 222 0 65004 i
*>       10.0.2.99 1011   32768 ?
* i     100.0.1.3 0 333 0 65003 65005 65004 i
*   50.0.1.5/32   100.0.2.4   222 0 65004 65005 i
* i     100.0.1.3 0 333 0 65003 65005 i
*>       10.0.2.99 1011   32768 ?
* i 50.0.1.99/32   10.0.1.99 2 100 0 ?
*>       10.0.2.99 11   32768 ?
* i 100.0.1.0/24   10.0.1.1 0 100 0 ?
*>       10.0.2.99 1011   32768 ?
*   100.0.2.0/24   100.0.2.4 0 222 0 65004 ?
*>       0.0.0.0 1   32768 ?
*   200.0.1.0   100.0.2.4   222 0 65004 65005 ?
*>       10.0.2.99 1011   32768 ?
* i     100.0.1.3 0 333 0 65003 ?
*   200.0.2.0   100.0.2.4 0 222 0 65004 ?
*>       10.0.2.99 1011   32768 ?
* i     100.0.1.3 0 333 0 65003 65005 ?
Regardons l'effet du poids (Weigth) sur le réseau 50.0.1.3: (en rouge ci-dessus)
Il y a deux routes pour 50.0.1.3, laquelle sera choisie?
Les poids (Weight) sont différents donc cela signifie que la route élue (indiquée avec le caractère ">") aura le poids le plus élevé (32768).

Regardons l'effet de la préférence locale (Local preference) sur le réseau 50.0.1.5: (en rouge ci-dessus)
Il y a deux routes pour 50.0.1.5, laquelle sera choisie?
Les poids (Weight) sont égaux (0) -> les préférences locales (Local preference) sont différentes. Cela signifie que la route élue (indiquée avec le caractère ">") aura la préférence locale (333) la plus haute.

Voir des informations sur le processus de sélection du chemin BGP.

Quagga_A#show route-map r2

OSPF:
route-map r2, permit, sequence 10
  Match clauses:
  Set clauses:
  Call clause:
  Action:
    Exit routemap
BGP:
route-map r2, permit, sequence 10
  Match clauses:
  Set clauses:
    local-preference 222
  Call clause:
  Action:
    Exit routemap
Haut de la page       Menu commandes show

CISCO 2651 B

Cisco_2651_B#show ip interface brief

Interface IP-Address OK? Method Status Protocol
FastEthernet0/1 100.0.1.3 YES NVRAM up up
FastEthernet0/1 200.0.1.3 YES NVRAM up up
Loopback1 50.0.1.3 YES NVRAM up up
Cisco_2651_B#show ip route

Codes:   C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route
       
Gateway of last resort is not set
       
    50.0.0.0/32 is subnetted, 6 subnets
C     50.0.1.3 is directly connected, Loopback1
B     50.0.1.2 [20/0] via 100.0.1.1, 00:46:33
B     50.0.1.1 [20/0] via 100.0.1.1, 00:47:02
B     50.0.1.5 [20/0] via 200.0.1.5, 00:46:30
B     50.0.1.4 [20/0] via 200.0.1.5, 00:46:00
B     50.0.1.99 [20/2] via 100.0.1.1, 00:47:02
    100.0.0.0/24 is subnetted, 2 subnets
C     100.0.1.0 is directly connected, FastEthernet0/0
B     100.0.2.0 [20/0] via 100.0.1.1, 00:22:34
C   200.0.1.0/24 is directly connected, FastEthernet0/1
B   200.0.2.0/24 [20/1] via 200.0.1.5, 00:46:30
    10.0.0.0/24 is subnetted, 3 subnets
B     10.0.2.0 [20/2] via 100.0.1.1, 00:47:02
B     10.0.1.0 [20/0] via 100.0.1.1, 00:47:03
Cisco_2651_B#show ip bgp summary

BGP router identifier 50.0.1.3, local AS number 65003
BGP table version is 14, main routing table version 14
13 network entries using 1261 bytes of memory
16 path entries using 576 bytes of memory
11 BGP path attribute entries using 660 bytes of memory
3 BGP AS-PATH entries using 72 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2569 total bytes of memory
BGP activity 13/0 prefixes, 16/0 paths, scan interval 60 secs
                   
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
100.0.1.1 4 65001 56 57 14 0 0 00:48:56 8
200.0.1.5 4 65005 57 58 14 0 0 00:47:26 5
Cisco_2651_B#show ip bgp

BGP table version is 16, local router ID is 50.0.1.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
      r RIB-failure, S Stale, R Removed
Origin codes: i - IGP, e - EGP, ? - incomplete
                 
    Network   Next Hop Metric LocPrf Weight Path
*>   10.0.1.0/24   100.0.1.1 0   0 65001 ?
*       200.0.1.5     0 65005 65004 65001 ?
*>   10.0.2.0/24   100.0.1.1 2   0 65001 ?
*       200.0.1.5     0 65005 65004 65001 ?
*>   50.0.1.1/32   100.0.1.1 0   0 65001 i
*>   50.0.1.2/32   100.0.1.1     0 65001 i
*       200.0.1.5     0 65005 65004 65001 i
*>   50.0.1.3/32   0.0.0.0 0   32768 i
*>   50.0.1.4/32   100.0.1.1     0 65001 65004 i
*       200.0.1.5     0 65005 65004 i
*>   50.0.1.5/32   200.0.1.5 0   0 65005 i
*>   50.0.1.99/32   100.0.1.1 2   0 65001 ?
*       200.0.1.5     0 65005 65004 65001 ?
*>   100.0.1.0/24   0.0.0.0 0   32768 ?
*       100.0.1.1 0   0 65001 ?
*>   100.0.2.0/24   100.0.1.1     0 65001 ?
*       200.0.1.5     0 65005 65004 ?
*>   200.0.1.0   0.0.0.0 0   32768 ?
*       200.0.1.5 1   0 65005 ?
*>   200.0.2.0   200.0.1.5 1   0 65005 ?
Regardons l'effet du chemin (Path) sur le réseau 10.0.2.0: (en rouge ci-dessus)
Il y a deux routes pour 10.0.2.0, laquelle sera choisie?

Les poids (Weight) sont égaux (0) -> les préférences locales (Local preference) ne sont pas configurées -> La longueur des chemins (Path) est différente. Cela signifie que la route élue (indiquée avec le caractère ">") aura la longueur de chemin la plus petite (1).

Voir des informations sur le processus de sélection du chemin BGP.

Haut de la page       Menu commandes show

QUAGGA B

Quagga_B#show interface description

Interface Status Protocol Description
eth0 up up  
eth1 up up  
lo up up  
Quagga_B#show ip route

Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
    I - ISIS, B - BGP, > - selected route, * - FIB route
     
B>*   10.0.1.0/24 [20/55] via 200.0.1.3, eth0, 01:14:47
B>*   10.0.2.0/24 [20/55] via 200.0.1.3, eth0, 01:14:47
B>*   50.0.1.1/32 [20/55] via 200.0.1.3, eth0, 01:14:47
B>*   50.0.1.2/32 [20/55] via 200.0.1.3, eth0, 01:14:47
B>*   50.0.1.3/32 [20/55] via 200.0.1.3, eth0, 01:14:47
B>*   50.0.1.4/32 [20/99] via 200.0.2.4, eth1, 01:14:45
C>*   50.0.1.5/32 is directly connected, lo
B>*   50.0.1.99/32 [20/55] via 200.0.1.3, eth0, 01:14:47
B>*   100.0.1.0/24 [20/55] via 200.0.1.3, eth0, 01:14:47
B>*   100.0.2.0/24 [20/99] via 200.0.2.4, eth1, 00:50:45
C>*   127.0.0.0/8 is directly connected, lo
C>*   200.0.1.0/24 is directly connected, eth0
C>*   200.0.2.0/24 is directly connected, eth1
Quagga_B#show ip bgp summary

BGP router identifier 50.0.1.5, local AS number 65005
RIB entries 25, using 1600 bytes of memory
Peers 2, using 5024 bytes of memory
                   
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
200.0.1.3 4 65003 85 85 0 0 0 01:16:00 10
200.0.2.4 4 65004 84 90 0 0 0 01:15:59 11
                   
Total number of neighbors 2
Quagga_B#show ip bgp

BGP table version is 0, local router ID is 50.0.1.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
      r RIB-failure, S Stale, R Removed
Origin codes: i - IGP, e - EGP, ? - incomplete
                 
    Network   Next Hop Metric LocPrf Weight Path
*   10.0.1.0/24   200.0.2.4 99   0 65004 65001 ?
*>       200.0.1.3 55   0 65003 65001 ?
*   10.0.2.0/24   200.0.2.4 99   0 65004 65001 ?
*>       200.0.1.3 55   0 65003 65001 ?
*   50.0.1.1/32   200.0.2.4 99   0 65004 65001 ?
*>       200.0.1.3 55   0 65003 65001 i
*   50.0.1.2/32   200.0.2.4 99   0 65004 65001 i
*>       200.0.1.3 55   0 65003 65001 i
*   50.0.1.3/32   200.0.2.4 99   0 65004 65001 ?
*>       200.0.1.3 55   0 65003 i
*>   50.0.1.4/32   200.0.2.4 99   0 65004 i
*   50.0.1.5/32   0.0.0.0 1   32768 ?
*>       0.0.0.0 0   32768 i
*   50.0.1.99/32   200.0.2.4 99   0 65004 65001 ?
*>       200.0.1.3 55   0 65003 65001 ?
*   100.0.1.0/24   200.0.2.4 99   0 65004 65001 ?
*>       200.0.1.3 55   0 65003 ?
*>   100.0.2.0/24   200.0.2.4 99   0 65004 ?
*       200.0.1.3 55   0 65003 65001 ?
*   200.0.1.0   200.0.1.3 55   0 65003 ?
*>       0.0.0.0 1   32768 ?
*   200.0.2.0   200.0.2.4 99   0 65004 ?
*>       0.0.0.0 1   32768 ?
Regardons l'effet de la MED (métrique) sur le réseau 10.0.1.0: (en rouge ci-dessus)
Il y a deux routes pour 10.0.1.0, laquelle sera choisie?

Les poids (Weight) sont égaux (0) -> les préférences locales (Local preference) ne sont pas configurées -> La longueur des chemins (Path) est égale (2) -> les codes d'origines sont égaux (caractère "?") -> les MED sont différentes. Cela signifie que la route élue (indiquée avec le caractère ">") aura la MED la plus petite (55).

Voir des informations sur le processus de sélection du chemin BGP.

Haut de la page       Menu commandes show

CISCO 2651 C

Cisco_2651_C#show ip interface brief

Interface IP-Address OK? Method Status Protocol
FastEthernet0/1 100.0.2.4 YES NVRAM up up
FastEthernet0/1 200.0.2.4 YES NVRAM up up
Loopback1 50.0.1.4 YES NVRAM up up
Cisco_2651_C#show ip route

Codes:   C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
      D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
      N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
      E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
      i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
      ia - IS-IS inter area, * - candidate default, U - per-user static route
      o - ODR, P - periodic downloaded static route
       
Gateway of last resort is not set
       
    50.0.0.0/32 is subnetted, 6 subnets
B     50.0.1.3 [20/1011] via 100.0.2.2, 00:41:28
B     50.0.1.2 [20/0] via 100.0.2.2, 00:41:28
B     50.0.1.1 [20/1011] via 100.0.2.2, 00:41:28
B     50.0.1.5 [20/0] via 200.0.2.5, 01:05:46
C     50.0.1.4 is directly connected, Loopback1
B     50.0.1.99 [20/11] via 100.0.2.2, 00:41:29
    100.0.0.0/24 is subnetted, 2 subnets
B     100.0.1.0 [20/1011] via 100.0.2.2, 00:41:28
C     100.0.2.0 is directly connected, Ethernet0/0
B   200.0.1.0/24 [20/1] via 200.0.2.5, 01:05:46
C   200.0.2.0/24 is directly connected, Ethernet0/1
    10.0.0.0/24 is subnetted, 3 subnets
B     10.0.2.0 [20/1] via 100.0.2.2, 00:41:28
B     10.0.1.0 [20/11] via 100.0.2.2, 00:41:30
Cisco_2651_C#show ip bgp summary

BGP router identifier 50.0.1.4, local AS number 65004
BGP table version is 24, main routing table version 24
13 network entries and 26 paths using 2197 bytes of memory
12 BGP path attribute entries using 624 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 16/26 prefixes, 31/2 paths, scan interval 15 secs
                   
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
100.0.2.2 4 65001 49 54 24 0 0 00:42:26 12
200.0.2.5 4 65005 81 76 24 0 0 01:06:44 11
Cisco_2651_C#show ip bgp

BGP table version is 0, local router ID is 50.0.1.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
      r RIB-failure, S Stale, R Removed
Origin codes: i - IGP, e - EGP, ? - incomplete
                 
    Network   Next Hop Metric LocPrf Weight Path
*>   10.0.1.0/24   100.0.2.2 11   0 65001 ?
*       200.0.2.5     0 65005 65003 65001 ?
*>   10.0.2.0/24   100.0.2.2 0   0 65001 ?
*       200.0.2.5     0 65005 65003 65001 ?
*>   50.0.1.1/32   100.0.2.2 1011   0 65001 ?
*       200.0.2.5     0 65005 65003 65001 i
*>   50.0.1.2/32   100.0.2.2 0   0 65001 i
*       200.0.2.5     0 65005 65003 65001 i
*>   50.0.1.3/32   100.0.2.2 1011   0 65001 ?
*       200.0.2.5     0 65005 65003 i
*>   50.0.1.4/32   0.0.0.0 0   32768 i
*   50.0.1.5/32   100.0.2.2 1011   0 65001 ?
*>       200.0.2.5 0   0 65005 i
*>   50.0.1.99/32   100.0.2.2 11   0 65001 ?
*       200.0.2.5     0 65005 65003 65001 ?
*>   100.0.1.0/24   100.0.2.2 1011   0 65001 ?
*       200.0.2.5     0 65005 65003 ?
*   100.0.2.0/24   100.0.2.2 1   0 65001 ?
*>       200.0.2.5 0   32768 ?
*   200.0.1.0   100.0.2.2 1011   0 65001 ?
*>       200.0.2.5 1   0 65005 ?
*   200.0.2.0   100.0.2.2 1011   0 65001 ?
*       200.0.2.5 1   0 65005 ?
*>       0.0.0.0 0   32768 ?
Regardons l'effet du code d'origine (origine code) sur le réseau 50.0.1.5: (en rouge ci-dessus)
Il y a deux routes pour 50.0.1.5, laquelle sera choisie?

Les poids (Weight) sont égaux (0) -> les préférences locales (Local preference) ne sont pas configurées -> La longueur des chemins (Path) est égale (1) -> les codes d'origines sont différents. Cela signifie que la route élue (indiquée avec le caractère ">") aura le code d'origine le plus petit (i).

Voir des informations sur le
processus de sélection du chemin BGP.

Cisco_2651_C#show route-map

route-map r99, permit, sequence 10
  Match clauses:
  Set clauses:
    metric 99
  Policy routing matches: 0 packets, 0 bytes
Haut de la page       Menu commandes show



5. TEST DE BASCULEMENT (FAILOVER SCENARIO)

Le but est d'éteindre le Switch 3750 L3 et de voir les changements dans les tables de routage sur Cisco 2651 A et Quagga A.
Cisco 2651 A devrait toujours être capable d'atteindre Quagga B mais via Quagga A à la place de Switch 3750 L3.


Comparaison des chemins de Cisco 2651 A vers Quagga B:
(ping recursif de Cisco 2651 A vers Quagga B)

10.0.1.99
100.0.1.1
200.0.1.3
50.0.1.5
50.0.1.5
100.0.1.3
10.0.1.1
10.0.1.99
10.0.2.99
100.0.2.2
200.0.2.4
50.0.1.5
50.0.1.5
100.0.2.4
10.0.2.2
10.0.2.99
Cisco 2651 A - Comparaison des meilleures routes: ("show ip route")

  50.0.0.0/32 is subnetted, 6 subnets
O E1   50.0.1.1 [110/1001] via 10.0.1.1, FastEth0/0
O E2   50.0.1.2 [110/2000] via 10.0.2.2, FastEth0/1
O E1   50.0.1.3 [110/1001] via 10.0.1.1, FastEth0/0
O E1   50.0.1.5 [110/1001] via 10.0.1.1, FastEth0/0
O E1   50.0.1.4 [110/1001] via 10.0.1.1, FastEth0/0
C   50.0.1.99 is directly connected, Loopback1
  100.0.0.0/24 is subnetted, 2 subnets
O E1   100.0.1.0 [110/1001] via 10.0.1.1, FastEth0/0
O E2   100.0.2.0 [110/2000] via 10.0.2.2, FastEth0/1
O E1 200.0.1.0/24 [110/2000] via 10.0.2.2, FastEth0/1
O E1 200.0.2.0/24 [110/2000] via 10.0.2.2, FastEth0/1
  10.0.0.0/24 is subnetted, 2subnets
C   10.0.1.0 is directly connected, FastEth0/0
C   10.0.2.0 is directly connected, FastEth0/1
  50.0.0.0/32 is subnetted, 5 subnets
   ------------------------
O E2   50.0.1.2 [110/2000] via 10.0.2.2, FastEth0/1
O E2   50.0.1.3 [110/2000] via 10.0.2.2, FastEth0/1
O E2   50.0.1.4 [110/2000] via 10.0.2.2, FastEth0/1
O E2   50.0.1.5 [110/2000] via 10.0.2.2, FastEth0/1
C   50.0.1.99 is directly connected, Loopback1
  100.0.0.0/24 is subnetted, 2 subnets
O E2   100.0.1.0 [110/2000] via 10.0.2.2, FastEth0/1
O E2   100.0.2.0 [110/2000] via 10.0.2.2, FastEth0/1
O E2 200.0.1.0/24 [110/2000] via 10.0.2.2, FastEth0/1
O E2 200.0.2.0/24 [110/2000] via 10.0.2.2, FastEth0/1
  10.0.0.0/24 is subnetted, 1 subnets
   ------------------------
C   10.0.2.0 is directly connected, FastEth0/1
Quagga A - Comparaison des meilleures routes: ("show ip route")

C>* 10.0.2.0/24 is directly connected, eth0
C>* 100.0.2.0/24 is directly connected, eth1
C>* 50.0.1.2/32 is directly connected, lo
O 10.0.2.0/24 [110/10] is directly connected, eth0
O>* 10.0.1.0/24 [110/11] via 10.0.2.99, eth0
O>* 50.0.1.1/32 [110/1011] via 10.0.2.99, eth0
O>* 50.0.1.3/32 [110/1011] via 10.0.2.99, eth0
O>* 50.0.1.4/32 [110/1011] via 10.0.2.99, eth0
O>* 50.0.1.5/32 [110/1011] via 10.0.2.99, eth0
O>* 50.0.1.99/32 [110/11] via 10.0.2.99, eth0
O>* 100.0.1.0/24 [110/1011] via 10.0.2.99, eth0
O>* 200.0.1.0/24 [110/1011] via 10.0.2.99, eth0
O>* 200.0.2.0/24 [110/1011] via 10.0.2.99, eth0
C>* 10.0.2.0/24 is directly connected, eth0
C>* 100.0.2.0/24 is directly connected, eth1
C>* 50.0.1.2/32 is directly connected, lo
O 10.0.2.0/24 [110/10] is directly connected, eth0
   ------------------------
   ------------------------
B>* 50.0.1.3/32 [20/0] via 100.0.2.4, eth1
B>* 50.0.1.4/32 [20/0] via 100.0.2.4, eth1
B>* 50.0.1.5/32 [20/0] via 100.0.2.4, eth1
O>* 50.0.1.99/32 [110/11] via 10.0.2.99, eth0
   ------------------------
B>* 200.0.1.0/24 [20/0] via 100.0.2.4, eth1
B>* 200.0.2.0/24 [20/0] via 100.0.2.4, eth1
Quagga A - Comparaison des routes BGP: ("show ip bgp")

* i 10.0.1.0/24 10.0.1.1 0 100 0 ?
*>     10.0.2.99 11   32768 ?
* i 10.0.2.0/24 10.0.1.99 2 100 0 ?
*>     0.0.0.0 1   32768 ?
* i 50.0.1.1/32 10.0.1.1 0 100 0 i
*>     10.0.2.99 1011   32768 ?
*   50.0.1.2/32 0.0.0.0 1   32768 ?
*>     0.0.0.0 0   32768 i
*>   50.0.1.3/32 10.0.2.99 1011   32768 ?
* i   100.0.1.3 0 333 0 65003 i
*   50.0.1.4/32 100.0.2.4 0 222 0 65004 i
*>     10.0.2.99 1011   32768 ?
* i   100.0.1.3 0 333 0 65003 65005 65004 i
*   50.0.1.5/32 100.0.2.4   222 0 65004 65005 i
* i   100.0.1.3 0 333 0 65003 65005 i
*>     10.0.2.99 1011   32768 ?
* i 50.0.1.99/32 10.0.1.99 2 100 0 ?
*>     10.0.2.99 11   32768 ?
* i 100.0.1.0/24 10.0.1.1 0 100 0 ?
*>     10.0.2.99 1011   32768 ?
*   100.0.2.0/24 100.0.2.4 0 222 0 65004 ?
*>     0.0.0.0 1   32768 ?
*   200.0.1.0 100.0.2.4   222 0 65004 65005 ?
*>     10.0.2.99 1011   32768 ?
* i   100.0.1.3 0 333 0 65003 ?
*   200.0.2.0 100.0.2.4 0 222 0 65003 ?
*>     10.0.2.99 1011   32768 ?
* i   100.0.1.3 0 333 0 65003 65005 ?
*> i 10.0.1.0/24 10.0.1.1 0 100 0 ?
   ------------------------
* i 10.0.2.0/24 10.0.1.99 2 100 0 ?
*>     0.0.0.0 1   32768 ?
*> i 50.0.1.1/32 10.0.1.1 0 100 0 i
   ------------------------
*   50.0.1.2/32 0.0.0.0 1   32768 ?
*>     0.0.0.0 0   32768 i
*>   50.0.1.3/32 100.0.2.4   222 0 65004 65005 65003 i
   ------------------------
*>   50.0.1.4/32 100.0.2.4 0 222 0 65004 i
   ------------------------
   ------------------------
*>   50.0.1.5/32 100.0.2.4   222 0 65004 65005 i
   ------------------------
   ------------------------
* i 50.0.1.99/32 10.0.1.99 2 100 0 ?
*>     10.0.2.99 11   32768 ?
   ------------------------
   ------------------------
*   100.0.2.0/24 100.0.2.4 0 222 0 65004 ?
*>     0.0.0.0 1   32768 ?
*>   200.0.1.0 100.0.2.4   222 0 65004 65005 ?
   ------------------------
   ------------------------
*>   200.0.2.0 100.0.2.4 0 222 0 65004 ?
   ------------------------
   ------------------------

Haut de la page






If you liked our tutorials, don't hesitate to support us and visit our sponsors!
Si vous aimez nos tutoriaux, n'hésitez pas à nous supporter et visiter nos sponsors!