TOTAL
Since dec 2006
1'942'871 Visitors
4'218'042 Pages

Nov 2010 Stats
82'909 Visitors
146'476 Pages
196 countries
Full statistics



Help us translate
our tutorials!

JOIN the
OpenManiak Team.
OM TEAM
Director:
Blaise Carrera
Tutorials creation:
Blaise Carrera
Translaters:
Giovanni Fredducci
Angel Chraniotis
Moham. H. Karvan
Alexandro Silva
Blaise Carrera
Andrei Chertolyas
Sergiy Uvarov
Nickola Kolev
Łukasz Nowatkowski
Ivo Raisr
Catalin Bivolaru
Bogdan A. Costea
Kirill Simonov
Oliver Mucafir
JaeYoung Jeon
Seungyoon Lee
Jie Yu & Si Cheng
Tao Wei
YukiAlex
Fumihito Yoshida
Muhammad Takdir
Çağdaş Tülek
Auditors
Leslie Luthi
Joe Anderson
Jennifer Ockwell
Nigel Titley
Alison Rees
Sabrina Barbey
Webmaster:
Blaise Carrera
VYATTA - The Easy Tutorial - Case Study 3 - OPSF Advanced

Vyatta Case 3 - OPSF Adv.
Last Change : Dec 07 2010


Tool
Install
Ergonomy
Forum



Details What is Vyatta?
Screenshots
Prerequisites
Tutorial Vyatta
Vyatta & Cisco Commands
Vyatta/Cisco/Quagga Comparison (Quagga section)
Case Study 1 - Static routes (VC 2.0)
Case Study 2 - OSPF simple (VC 2.0)
Case Study 3 - OSPF advanced (VC 2.0)
Case Study 4 - BGP (VC 3.0)
Case Study 5 - VRRP (VC 2.2)
Case Study 6 - NAT (VC 2.0)
Case Study 7 - DHCP (VC 2.2)
Case Study 8 - IPSec (VC 2.2)
Case Study 9 - Packages (VC 3.0)
Case Study 10 - Bridging (VC 3.0)
Case Study 11 - CDP VC 3.0




If you like our tutorials, don't hesitate to support us and visit our sponsors!
Si vous aimez nos tutoriaux, n'hésitez pas à nous supporter et visiter nos sponsors!



1. CASE PRINCIPLE 2. PICTURE 3. CONFIGURATIONS 4. SHOW COMMANDS
See a similar scenario with the Quagga router.


1. CASE PRINCIPLE

Vyatta version used: VC 2.0 Feb 20, 2007
We will test in this third example a medium difficulty level environment where two desktops are linked together with two OPSF areas, one OSPF area is tagged as stub area. Other Vyatta functionalities listed below are tested in the same time.

The Vyatta A router and the Layer 3 Switch are located in a stub area. They have OPSF intra (O) and inter-area routes (OIA) in their routing tables but no external OSPF route. To route these external OPSF networks like 10.200.1.4 (see next paragraph), there is a default OSPF route to the border router (Vyatta A router) on the routers inside area 1.
Vyatta A is a border router because it is in area 0 or backbone area and in area 1.

For the purpose of our case study, the 10.200.1.4 static route is redistributed into OSPF on the Vyatta B router to "artificially" create an external OPSF network tagged as OE2. Because of the stub area, this network should not be propagated on the Vyatta A router and the Layer 3 Switch.


Please be aware that the Vyatta ntp synchronization and dhcp relay settings do not work on Vyatta VC2.
Read the Vyatta policy about the Community Edition.


2. PICTURE

vyatta cisco case study opsf advanced 3750 2651 Functionalities tested:

(click on the web links to have more details about a protocol)

Interface settings
OSPF - backbone area
OSPF - multi area
OSPF - stub area
Static routing
Redistribution - static to OSPF
DHCP server
SNMP settings
Syslog settings
802.1Q - trunking
SSH access
Telnet access
ntp synchronization
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 


3. CONFIGURATIONS

SWITCH LAYER 2 IOS: 12.2-25.SEB4 See the entire configuration
interface GigabitEthernet 1/0/1
  description Vyatta_A
  switchport mode trunk
  switchport trunk encapsulation dot1q
interface GigabitEthernet1/0/2
  description DHCP_client
  switchport access vlan 2
interface GigabitEthernet1/0/3
  switchport access vlan 3
interface GigabitEthernet1/0/4
  switchport access vlan 100
interface vlan 1
  shutdown
interface vlan 2
  ip address 10.101.2.1 255.255.255.0
interface vlan 3
  ip address 10.101.3.1 255.255.255.0
interface vlan 100
  ip address 10.101.1.1 255.255.255.0
ip default-gateway 10.101.1.2
logging 10.102.1.99
logging trap debugging
snmp-server community TeddyBear RO 50
access-list 50 permit 10.102.1.99
line vty 0 4
  no login
enable secret password
ntp server 10.1.2.2
VYATTA A ROUTER VC2 Feb 20, 2007 See the entire configuration
set interfaces ethernet eth0
edit interfaces ethernet eth0
  set description Switch_Layer3
  set address 10.100.1.2 prefix-length 24
set interfaces ethernet eth1
edit interfaces ethernet eth1
  set description Switch_Layer2
  set vif 2 address 10.101.2.2 prefix-length 24
  set vif 3 address 10.101.3.2 prefix-length 24
  set vif 100 address 10.101.1.2 prefix-length 24
set interfaces loopback lo
edit interfaces loopback lo
  set address 10.200.1.1 prefix-length 32
set protocols ospf4
edit protocols ospf4
  set router-id 10.200.1.1
  set area 0.0.0.1 area-type stub
  set area 0.0.0.1 interface lo address 10.200.1.1
  set area 0.0.0.1 interface eth0 address 10.100.1.2
  set area 0.0.0.1 interface eth1.2 address 10.101.2.2
  set area 0.0.0.1 interface eth1.3 address 10.101.3.2
  set area 0.0.0.1 interface eth1.100 address 10.101.1.2
set protocols snmp
edit protocols snmp
  set community TeddyBear authorization ro
  set community TeddyBear client 10.102.1.99
  set community TeddyBear location Paris-router
  set community TeddyBear contact Guillaume
edit system
  set host-name VyattaA
  set ntp-server 10.1.2.2
  delete ntp-server 69.59.150.135
  set login user vyatta authentification plaintext-password password
  set login user root authentification plaintext-password password
set service dhcp-server name server1
edit service dhcp-server name server1
  set start 10.101.2.101 stop 10.101.2.120
  set default-router 10.101.2.2
  set network-mask 24
  set interface eth1.2
set system syslog host 10.102.1.99 facility * level info
set service telnet
set service ssh
commit
SWITCH LAYER 3 IOS: 12.2-25.SEE2 See the entire configuration
hostname 3750-Cisco
ip routing
ip multicast-routing distributed
interface Vlan1
  ip address 10.100.1.1 255.255.255.0
interface Vlan2
  ip address 10.100.2.1 255.255.255.0
interface FastEthernet1/0/1
  description Vyatta_A
interface FastEthernet1/0/2
  description Vyatta_B
  switchport access vlan 2
interface Loopback1
  ip address 10.200.1.3 255.255.255.255
router ospf 1
  area 1 stub
  network 10.100.1.0 0.0.0.255 area 1
  network 10.100.2.0 0.0.0.255 area 1
  network 10.200.1.3 0.0.0.0 area 1
logging trap informational
logging 10.102.1.99
access-list 50 permit 10.102.1.99
snmp-server community TeddyBear RO 50
ip domain-name domain.net
crypto key generate rsa
line vty 0 4
  no login
enable secret password
ntp server 10.1.2.2
VYATTA B ROUTER VC2 Feb 20, 2007 See the entire configuration
set interfaces ethernet eth0
edit interfaces ethernet eth0
  set description Switch_Layer3
  set address 10.100.2.2 prefix-length 24
set interfaces ethernet eth1
edit interfaces ethernet eth1
  set description Cisco_2651
  set address 10.1.2.1 prefix-length 24
set interfaces loopback lo
edit interfaces loopback lo
  set address 10.200.1.2 prefix-length 32
set protocols ospf4
edit protocols ospf4
  set router-id 10.200.1.2
  set area 0.0.0.0 interface eth1 address 10.1.2.1
  set area 0.0.0.0 interface lo address 10.200.1.2
  set area 0.0.0.1 area-type stub
  set area 0.0.0.1 default-lsa disable false
  set area 0.0.0.1 interface eth1 address 10.100.2.2
  set export static-to-OPSF
set protocols static route 10.200.1.4/32 next-hop 10.1.2.2
set protocols snmp
edit protocols snmp
  set community TeddyBear authorization ro
  set community TeddyBear client 10.102.1.99
  set community TeddyBear location London-router
  set community TeddyBear contact Philou
set policy policy-statement static-to-OSPF
edit policy policy-statement static-to-OSPF
  set term from protocol static
  set term then action accept
edit system
  set host-name VyattaB
  set ntp-server 10.1.2.2
  delete ntp-server 69.59.150.135
  set login user vyatta authentification plaintext-password password
  set login user root authentification plaintext-password password
set system syslog host 10.102.1.99 facility * level info
set service telnet
set service ssh
commit
CISCO 2651 IOS: 12.2-23a See the entire configuration
hostname cisco-2651
interface FastEthernet 0/0
  description Vyatta B router
  ip address 10.1.2.2 255.255.255.0
interface FastEthernet 0/1
  description SNMP/Syslog/TFTP server
  ip address 10.102.1.1 255.255.255.0
interface Loopback1
  ip address 10.200.1.4 255.255.255.255
router ospf 1
  network 10.1.2.0 0.0.0.255 area 0
  network 10.102.1.0 0.0.0.255 area 0
logging trap informational
logging 10.102.1.99
access-list 50 permit 10.102.1.99
snmp-server community TeddyBear RO 50
line vty 0 4
  no login
enable secret password
ntp master


Desktop A Microsoft Windows Config
Desktop B Microsoft Windows Config

Save the configurations on the 10.102.1.99 TFTP server:

Cisco_device#copy run tftp
Vyatta_device#save tftp://10.102.1.99/vyatta.conf

SNMP check from the SNMP server (Ubuntu or Debian):

Install SNMP server:
#apt-get install snmp

snmpstatus -vcommunity_level -c community_name ip_address
example:
#snmpstatus -v2c -c TeddyBear 10.100.2.2

Top of the page



4. SHOW COMMANDS

SWITCH LAYER 2

Switch_L2#show ip route

cisco output show ip route

Switch_L2#show interfaces GigabitEthernet 1/0/1 trunk

cisco output show  interfaces GigabitEthernet 1/0/1 trunk

Switch_L2#show ntp associations

cisco output show ntp associations

VYATTA A ROUTER

vyatta@VyattaA#show route

vyatta output show route

vyatta@VyattaA#show ospf4 neighbor

vyatta output show ospf4 neighbor

vyatta@VyattaA#show ospf4 database

vyatta output show ospf4 database

vyatta@VyattaA#show dhcp lease

vyatta output show dhcp lease

vyatta@VyattaA#show dhcp statistics

vyatta output show dhcp statistics

vyatta@VyattaA#show ntp associations

vyatta output show ntp associations

SWITCH LAYER 3

3750-Cisco#show ip route

cisco output show ip route

3750-Cisco#show ip ospf neighbor

cisco output show ip ospf neighbor

3750-Cisco#show ip ospf database

cisco output show ip ospf database

3750-Cisco#show ntp associations

cisco output show ntp associations

VYATTA B ROUTER

vyatta@VyattaB#show route

vyatta output show route

vyatta@VyattaB#show ospf4 neighbor

vyatta output show ospf4 neighbor

vyatta@VyattaB#show ospf4 database

vyatta output show ospf4 database

vyatta@VyattaB#show ntp associations

vyatta output show ntp associations

ROUTER 2651

cisco-2651#show ip route

cisco output show ip route

cisco-2651#show ip ospf neighbor

cisco output show ip ospf neighbor

cisco-2651#show ip ospf database

cisco output show ip ospf database

cisco-2651#show ntp associations

cisco output show ntp associations

cisco-2651#show ntp status

cisco output show ntp status

END TO END CONNECTIVITY CHECKS:

From Desktop A to Desktop B
C:\>tracert 10.102.1.99

windows output tracert

From Desktop B to Desktop A
C:\>tracert 10.101.2.119

windows output tracert

Top of the page





If you liked our tutorials, don't hesitate to support us and visit our sponsors!
Si vous aimez nos tutoriaux, n'hésitez pas à nous supporter et visiter nos sponsors!