TOTAL
Since dec 2006
1'942'871 Visitors
4'218'042 Pages

Nov 2010 Stats
82'909 Visitors
146'476 Pages
196 countries
Full statistics



Help us translate
our tutorials!

JOIN the
OpenManiak Team.
OM TEAM
Director:
Blaise Carrera
Tutorials creation:
Blaise Carrera
Translaters:
Giovanni Fredducci
Angel Chraniotis
Moham. H. Karvan
Alexandro Silva
Blaise Carrera
Andrei Chertolyas
Sergiy Uvarov
Nickola Kolev
Łukasz Nowatkowski
Ivo Raisr
Catalin Bivolaru
Bogdan A. Costea
Kirill Simonov
Oliver Mucafir
JaeYoung Jeon
Seungyoon Lee
Jie Yu & Si Cheng
Tao Wei
YukiAlex
Fumihito Yoshida
Muhammad Takdir
Çağdaş Tülek
Auditors
Leslie Luthi
Joe Anderson
Jennifer Ockwell
Nigel Titley
Alison Rees
Sabrina Barbey
Webmaster:
Blaise Carrera
VYATTA - The Easy Tutorial - Case Study 4 - BGP

Vyatta Case 4 - BGP
Last Change : Dec 07 2010


Tool
Install
Ergonomy
Forum



Details What is Vyatta?
Screenshots
Prerequisites
Tutorial Vyatta
Vyatta & Cisco Commands
Vyatta/Cisco/Quagga Comparison (Quagga section)
Case Study 1 - Static routes (VC 2.0)
Case Study 2 - OSPF simple (VC 2.0)
Case Study 3 - OSPF advanced (VC 2.0)
Case Study 4 - BGP (VC 3.0)
Case Study 5 - VRRP (VC 2.2)
Case Study 6 - NAT (VC 2.0)
Case Study 7 - DHCP (VC 2.2)
Case Study 8 - IPSec (VC 2.2)
Case Study 9 - Packages (VC 3.0)
Case Study 10 - Bridging (VC 3.0)
Case Study 11 - CDP VC 3.0




If you like our tutorials, don't hesitate to support us and visit our sponsors!
Si vous aimez nos tutoriaux, n'hésitez pas à nous supporter et visiter nos sponsors!


See a similar scenario with the Quagga router.


1. CASE PRINCIPLE

BE CAREFUL, THIS CASE STUDY HAS NOT BEEN VALIDATED

The configurations below are for information ONLY!!!

We noticed that under Vyatta VC 3.0 the OSPF -> BGP redistribution leads to the BGP process crash.



Unfortunately, we cannot provide you the results of our tests because of some bugs crashing the bgp routing table.
Read the Vyatta policy about the Community Edition.

https://bugzilla.vyatta.com/show_bug.cgi?id=932
https://bugzilla.vyatta.com/show_bug.cgi?id=1469



2. PICTURE

vyatta cisco case study BGP Functionalities tested:

(click on the web links to have more details about a protocol)

Interface settings
OSPF - backbone area
BGP
Redistr. - BGP to OSPF
Redistr. - OSPF to BGP
Telnet access

 
 
 
 
 
 
 
   
 
 
 
 
   
 
 
 
 
   
 
 
 
 
   
 
 
 
 
 
 
 
Top of the page




3. CONFIGURATIONS

ROUTERS CONFIGURATIONS

ROUTER 2651 A IOS: 12.2-23a
See the entire configuration
 

 
 
interface FastEthernet0/1
  ip address 10.0.2.99 255.255.255.0
  no shutdown
interface FastEthernet0/0
  ip address 10.0.1.99 255.255.255.0
  no shutdown
interface Loopback 1
  ip address 50.0.1.99 255.255.255.255
Cisco_2651_A
router ospf 1
  network 10.0.1.0 0.0.0.255 area 0
  network 10.0.2.0 0.0.0.255 area 0
  network 50.0.1.99 0.0.0.0 area 0
line vty 0 4
  no login
enable secret password

SWITCH L3 3750
IOS: 12.2-25.SEE4
See the entire configuration
 

VYATTA A
VC 3.0 Oct 29, 2007
See the entire configuration
 
interface vlan 1
  ip address 10.1.1.2 255.255.255.0
  no shutdown
interface FastEthernet1/0/1
  switchport access vlan 1
edit interfaces ethernet eth0
  set address 10.0.2.2 prefix-length 24
  
  
  
interface vlan 2
  ip address 100.0.1.1 255.255.255.0
  no shutdown
interface FastEthernet1/0/2
  switchport access vlan 2
edit interfaces ethernet eth1
  set address 100.0.2.2 prefix-length 24
  
  
  
interface Loopback 1
  ip address 50.0.1.1 255.255.255.255
edit interfaces loopback lo
  set address 50.0.1.2 prefix-length 32
hostname Cisco_3750_L3 set system host-name Vyatta-A
 








 
set policy policy-statement to-OSPF
edit policy policy-statement to-OSPF
  set term 1 from protocol connected
  set term 1 then metric 2000
  set term 1 then action accept
  set term 2 from protocol bgp
  set term 2 then metric 2000
  set term 2 then action accept
router ospf 1

  network 10.0.1.0 0.0.0.255 area 0

  redistribute connected metric 1000
  metric-type 1 subnets
  redistribute bgp 65001 metric 1000
  metric-type 1 subnets
set protocols ospf4
edit protocols ospf4
  set area 0.0.0.0 interface eth0 address 10.0.2.2
  set router-id 50.0.1.2
  set export to-OSPF
 






 
set policy policy-statement to-BGP
edit policy policy-statement to-BGP
  set term 1 from protocol connected
  set term 1 then action accept
  set term 2 from protocol ospf4
  set term 2 then action accept
 
router bgp 65001
  no synchronization
  bgp router-id 50.0.1.1
  network 50.0.1.1 mask 255.255.255.255
  redistribute connected
  redistribute ospf 1
  neighbor 10.0.2.2 remote-as 65001
  neighbor 100.0.1.3 remote-as 65003
  neighbor 100.0.1.3 route-map r2 in
  no auto-summary

 
set protocols bgp
edit protocols bgp
  set bgp-id 50.0.1.2
  set local-as 65001
  set peer 10.0.1.1 as 65001
  set peer 10.0.1.1 local-ip 10.0.2.2
  set peer 10.0.1.1 next-hop 10.0.2.2
  set peer 100.0.2.4 as 65004
  set peer 100.0.2.4 local-ip 100.0.2.2
  set peer 100.0.2.4 next-hop 100.0.2.2
  set peer 100.0.2.4 import LocalPref
  set export to-BGP
route-map r2 permit 10
  set local-preference 333

 
set policy policy-statement LocalPref
edit policy policy-statement LocalPref
  set term 1 then localpref 222
  set term 1 then action accept
line vty 0 4
  no login
set service telnet
  
enable secret password
 

 
ip routing
ip multicast-routing distributed

ROUTER 2651 B
IOS: 12.2-23a
See the entire configuration
 

VYATTA B
VC 3.0 Oct 29, 2007
See the entire configuration
 
interface FastEthernet0/0
  ip address 100.0.1.3 255.255.255.0
  no shutdown
edit interfaces ethernet eth0
  set address 200.0.1.5 prefix-length 24
  
interface FastEthernet0/1
  ip address 200.0.1.3 255.255.255.0
  no shutdown
edit interfaces ethernet eth1
  set address 200.0.2.5 prefix-length 24
  
interface Loopback 1
  ip address 50.0.1.3 255.255.255.255
edit interfaces loopback lo
  set address 50.0.1.5 prefix-length 32
hostname Cisco_2651_B set system host-name Vyatta-B
set policy policy-statement to-BGP
edit policy policy-statement to-BGP
  set term 1 from protocol connected
  set term 1 then action accept
router bgp 65003
  bgp router-id 50.0.1.3
  network 50.0.1.3 mask 255.255.255.255
  redistribute connected
  neighbor 100.0.1.1 remote-as 65001
  neighbor 200.0.1.5 remote-as 65005
  neighbor 200.0.1.5 route-map r3 out
  no auto-summary
set protocols bgp
edit protocols bgp
  set bgp-id 50.0.1.5
  set local-as 65005
  set peer 200.0.1.3 as 65003
  set peer 200.0.1.3 local-ip 200.0.1.5
  set peer 200.0.1.3 next-hop 200.0.1.5
  set peer 200.0.2.4 as 65004
  set peer 200.0.2.4 local-ip 200.0.2.5
  set peer 200.0.2.4 next-hop 200.0.2.5
  set export to-BGP
route-map r3 permit 10
  set metric 55
line vty 0 4
  no login
set service telnet
 
enable secret password

ROUTER 2651 C IOS: 12.2-46a
See the entire configuration
 

 
 
interface FastEthernet0/0
  ip address 100.0.2.4 255.255.255.0
  no shutdown
interface FastEthernet0/1
  ip address 200.0.2.4 255.255.255.0
  no shutdown
interface Loopback 1
  ip address 50.0.1.4 255.255.255.255
router bgp 65004
  bgp router-id 50.0.1.4
  network 50.0.1.4 mask 255.255.255.255
  redistribute connected
  neighbor 100.0.2.2 remote-as 65001
  neighbor 200.0.2.5 remote-as 65005
  neighbor 200.0.2.5 route-map r99 out
  no auto-summary
hostname Cisco_2651_C
route-map r99 permit 10
  set metric 99
line vty 0 4
  no login
enable secret password
BE CAREFUL, THIS CASE STUDY HAS NOT BEEN VALIDATED

The configurations provided are for information ONLY!!!

We noticed that under Vyatta VC 3.0 the OSPF -> BGP redistribution leads to the BGP process crash.
Top of the page



4. SHOW COMMANDS






If you liked our tutorials, don't hesitate to support us and visit our sponsors!
Si vous aimez nos tutoriaux, n'hésitez pas à nous supporter et visiter nos sponsors!