TOTAL
Since dec 2006
1'942'871 Visitors
4'218'042 Pages

Nov 2010 Stats
82'909 Visitors
146'476 Pages
196 countries
Full statistics



Help us translate
our tutorials!

JOIN the
OpenManiak Team.
OM TEAM
Director:
Blaise Carrera
Tutorials creation:
Blaise Carrera
Translaters:
Giovanni Fredducci
Angel Chraniotis
Moham. H. Karvan
Alexandro Silva
Blaise Carrera
Andrei Chertolyas
Sergiy Uvarov
Nickola Kolev
Łukasz Nowatkowski
Ivo Raisr
Catalin Bivolaru
Bogdan A. Costea
Kirill Simonov
Oliver Mucafir
JaeYoung Jeon
Seungyoon Lee
Jie Yu & Si Cheng
Tao Wei
YukiAlex
Fumihito Yoshida
Muhammad Takdir
Çağdaş Tülek
Auditors
Leslie Luthi
Joe Anderson
Jennifer Ockwell
Nigel Titley
Alison Rees
Sabrina Barbey
Webmaster:
Blaise Carrera
VYATTA - The Easy Tutorial - Case Study 1 - Static Routing

Vyatta Case 1 - Static Routing
Last Change : Dec 26 2007


Tool
Install
Ergonomy
Forum



Details What is Vyatta?
Screenshots
Prerequisites
Tutorial Vyatta
Vyatta & Cisco Commands
Vyatta/Cisco/Quagga Comparison (Quagga section)
Case Study 1 - Static routes (VC 2.0)
Case Study 2 - OSPF simple (VC 2.0)
Case Study 3 - OSPF advanced (VC 2.0)
Case Study 4 - BGP (VC 3.0)
Case Study 5 - VRRP (VC 2.2)
Case Study 6 - NAT (VC 2.0)
Case Study 7 - DHCP (VC 2.2)
Case Study 8 - IPSec (VC 2.2)
Case Study 9 - Packages (VC 3.0)
Case Study 10 - Bridging (VC 3.0)
Case Study 11 - CDP VC 3.0




If you like our tutorials, don't hesitate to support us and visit our sponsors!
Si vous aimez nos tutoriaux, n'hésitez pas à nous supporter et visiter nos sponsors!



1. CASE PRINCIPLE 2. PICTURE 3. CONFIGURATIONS 4. SHOW COMMANDS
See a similar scenario with the Quagga router.


1. CASE PRINCIPLE

Vyatta version used: VC 2.0 Feb 20, 2007
In this first case study, we will see a very simple example where the routing is done with only static routes.


Read the Vyatta policy about the Community Edition.


2. PICTURE

vyatta cisco 2651 3750 static routing Functionalities tested:

Interface settings
Static routes
Telnet access

 
 
   
 
 
 
 
 
 
 
 


3. CONFIGURATIONS

CISCO ROUTER 2651 VYATTA A ROUTER
interface FastEthernet0/1
  ip address 10.1.3.2 255.255.255.0
edit interfaces ethernet eth0
  set address 10.1.3.1 prefix-length 24
interface FastEthernet0/0
  ip address 10.1.4.2 255.255.255.0
edit interfaces ethernet eth1
  set address 10.1.1.1 prefix-length 24
hostname Cisco-2651 set system host-name VyattaA
ip route 10.1.0.0 255.255.0.0 10.1.3.1
 
ip route 10.200.1.4 255.255.255.255 10.1.4.1
ip route 10.200.1.1 255.255.255.255 10.1.3.1
set protocols static route 10.1.0.0/16 next-hop 10.1.3.2
set protocols static route 10.200.1.4/32 next-hop 10.1.3.2
set protocols static route 10.200.1.1/32 next-hop 10.1.1.2
line vty 0 4
  no login
set service telnet
 
enable secret password
 
edit system login user vyatta
set authentification plaintext-password password

CISCO SWITCH L3 3750

VYATTA B ROUTER
interface vlan 1
  ip address 10.1.1.2 255.255.255.0
edit interfaces ethernet eth1
  set address 10.1.4.1 prefix-length 24
interface Loopback 1
  ip address 10.200.1.1 255.255.255.255
edit interfaces loopback lo
  set address 10.200.1.4 prefix-length 32
hostname 3750_L3 set system host-name VyattaB
ip route 0.0.0.0 0.0.0.0 10.1.1.1 set system static gateway-address 10.1.4.2
line vty 0 4
no login
set service telnet
 
enable secret password
 
edit system login user vyatta
set authentification plaintext-password password
ip routing
ip multicast-routing distributed
SEE THE ENTIRE CONFIGURATION OF THE DEVICES:

VyattaA
VyattaB
Cisco 2651
Cisco 3750 L3


4. SHOW COMMANDS

ROUTING TABLE

vyatta@VyattaA#show route

vyatta output show route

Cisco-2651#show ip route

cisco output show ip route

vyatta@VyattaB#show route

vyatta output show route

3750_L3#show ip route

cisco output show ip route

INTERFACES

vyatta@VyattaA#show interfaces ethernet eth0 physical

vyatta output show interfaces ethernet eth0 physical

vyatta@VyattaA#show interfaces ethernet eth0 statistics

vyatta output show interfaces ethernet eth0 statistics

Cisco-2651#show ip interface brief

cisco output show ip interface brief

Cisco-2651#show ip interface FastEthernet 0/1

cisco output show ip interface FastEthernet 0/1


vyatta@VyattaA#show version

vyatta output show version

Cisco-2651#show version

cisco output show version

Top of the page





If you liked our tutorials, don't hesitate to support us and visit our sponsors!
Si vous aimez nos tutoriaux, n'hésitez pas à nous supporter et visiter nos sponsors!